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How to fix images
Other than correcting color, one of the most common tasks you will perform in Adobe Photoshop is 
fixing images. You might be performing a photographic restoration (Figure 1), or correcting 
imperfections or problems that result from a photo-taking process. 

This guide covers several ways to retouch photos using Retouching tools, including use of the Spot Healing Brush tool, 
the Red Eye tool, the Patch tool, and the Content-Aware Move tool. Smart Sharpen and Camera Shake Reduction can 
help fix blurred images. Use these tools individually, or in combination to fine-tune your photo retouching tasks. 
Download the assets used in this tutorial here.

Using the History panel

Because retouching can require trial and error, you should know how to use the History panel to undo steps.

Like most computer users, you’re probably aware of the Undo command available in many applications. This 
command lets you undo the effects of whatever command you’ve just applied.

Figure 1 Before (left) and after (right) states of a complete photographic restoration

https://adobe.ly/2ymfMP0


2How to fix images  Photoshop Guide© 2018 Adobe Systems Incorporated. 
This document requires Adobe Photoshop CC 2018. Technical instructions may differ depending on your version.

Photoshop takes the Undo command several steps further with the History panel. The History panel keeps track of the 
last 20 commands you’ve applied to an image, allowing you to revert to any one of these. When you execute a 
command, such as transforming an image or adding text, these are added to the History panel. The commands appear 
in the list in the order in which you performed them. Each command is listed with the name of the tool or command 
you used to change the image.

You can also take a “snapshot” of a particular set of commands, allowing you to revert to this snapshot later.

Note: Although the History panel is great, it does consume memory (RAM), as do layers. So, if you’re working with a 
complex, multi-layered image, you may want to reduce the number of History commands saved. You can do so by 
choosing Edit > Preferences > Performance (Windows) or Photoshop > Preferences > Performance (Mac OS).

To use the History panel:

1.	 Open an image in Photoshop.

2.	 Click the History button in the right-side panel set (or 
choose Window > History) to open the History panel 
(Figure 2).

3.	 Execute several commands—such as selecting a part 
of the image, applying a filter, and adding a layer.

The point here is to add some commands to the 
History panel.

4.	 Click one of the earlier commands, such as Move 
(Figure 3).

Observe that the image reverts to its appearance at 
the time this command was executed. Any commands 
executed afterward are temporarily discarded and 
appear dimmed. In Figure 3, for example, the Eraser, 
Paint Bucket, New Layer are dimmed, and the effects 
no longer appear in the image.

At this point, the later commands are still available in 
the panel (if you select either). However, if you 
execute another command, the dimmed commands 
will be permanently discarded.

5.	 To delete a command, select it and then click the 
Delete button (Figure 3).

The image permanently reverts to the command prior 
to the deleted command.

Figure 3 Earlier command selected

Delete 
button

Figure 2 History panel

History 
button
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Taking a snapshot
You can use the Snapshot feature to capture the image as it appears at any point in the list of History commands. Once 
you’re satisfied with an image, it’s a good idea to take a snapshot.

To take a snapshot:

1.	 Click the History command you want to capture.

2.	 Click the Snapshot button (Figure 4).

3.	 Scroll to the top of the History panel as necessary to 
view the snapshot (Figure 3).

4.	 To revert to the snapshot, click it as you would any 
other History command.

You can compare different snapshots by clicking on 
them.

Using the Spot Healing Brush tool

The Spot Healing Brush tool (Figure 5) quickly removes details, blemishes and other imperfections in your photos. The 
Spot Healing Brush works similarly to the Healing Brush: it paints with sampled pixels from an image or pattern and 
matches the texture, lighting, transparency, and shading of the sampled pixels to the pixels being healed. Unlike the 
Healing Brush, the Spot Healing Brush doesn’t require you to specify a sample spot. The Spot Healing Brush 
automatically samples from around the retouched area.

Note: If you need to retouch a large area or need to better define the source sampling area, you can use the Healing 
Brush instead of the Spot Healing Brush.

Figure 4 Snapshots in the History panel

Snapshots

Take a 
Snapshot 
button

Figure 5 Retouching tools, with Spot Healing Brush Tool selected
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To use the Spot Healing Brush tool:

1.	 Click the Spot Healing Brush Tool in the Tools panel  
(Figure 5).

The pointer changes to a brush. Usually, the brush 
appears as a circle.

2.	 You can change the size or shape of the brush in the 
Options bar (Figure 6).

The brush should be large enough to cover the entire 
spot, with some room around the edges.

3.	 Confirm that the Content-Aware option is selected.

Content-Aware seamlessly fills the selection with 
similar image content from nearby. For the best 
results, create a selection that extends slightly into the 
area you want to replicate.

4.	 Position the Spot Healing Brush Tool over the area 
you want to correct (Figure 7).

5.	 Click to apply the correction (Figure 8).

Figure 7 Spot Healing brush positioned over a detail

Figure 6 Spot Healing Brush options

Figure 8 Spot Healing brush applied
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Using the Red Eye tool

When you take photos with a flash, red eye can often result. You can quickly correct red eye in flash photos of 
people or animals with the Red Eye tool.

To use the Red Eye tool:

1.	 Click the Red Eye Tool in the Tools panel (Figure 9).

2.	 Position the Red Eye Tool over the pupil you want to 
correct (Figure 10) and click to apply.

3.	 If you are not satisfied with the result, undo the 
correction, set one or more of the following options in 
the options bar (Figure 11), and click the red eye again.

Pupil Size increases or decreases the area affected by 
the Red Eye tool.

Darken Amount sets the darkness of the correction.

4.	 Click to apply the correction (Figure 12).

Figure 9 Red Eye tool

Figure 11 Red Eye tool options

Figure 12 Red Eye tool applied

Figure 10 Position Red Eye tool over eye to be fixed
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Using the Patch tool

The Patch tool lets you repair a selected area with pixels from another area or a pattern. The Patch tool matches 
the texture, lighting, and shading of the sampled pixels to the source pixels, making an imperfection disappear 
into the surrounding image. You can also use the Patch tool to clone isolated areas of an image.

Note: When repairing with pixels from the image, select a small area to produce the best result.

To use the Patch tool:

1.	 Identify the object you want to remove from an 
image. 

For example, you can remove the lightpost from a 
tourist landmark photo.

2.	 Select the Patch Tool (Figure 9).

3.	 Drag in the image to select the area you want to 
repair, and confirm that the Source option is selected 
in the options bar (Figure 13).

Note: You can also make a selection prior to selecting 
the Patch tool.

4.	 To adjust the selection, do one of the following:

•	 Shift-drag in the image to add to the existing 
selection.

•	 Alt-drag (Windows) or Option-drag (Mac OS) in 
the image to subtract from the existing selection.

•	 Alt+Shift-drag (Windows) or Option+Shift-drag 
(Mac OS) in the image to select an area 
intersected by the existing selection.

5.	 Position the pointer inside the selection, and drag the 
selection border to the area from which you want to 
sample (Figure 14). When you release the mouse 
button, the originally selected area is patched with the 
sampled pixels (Figure 15).

Figure 13 Patch tool options

Figure 14 Drag the selection to the sample area

Figure 15 The patched image
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Using the Content-Aware Move tool

The Content-Aware Move tool functions in a similar way to the Patch tool, with the exception that dragging a 
selection relocates a selected part of an image to a new location. The Content-Aware Move tool automatically 
samples from around the selection area are to blend together the moved content with the background pixels.

To use the Content-Aware Move tool:

1.	 Identify the object you want to move in an image.

For example, continuing work to on the tourist 
landmark photo shown in Figure 15, it might be 
preferable to move the right-most building away from 
the looming office building on the left.

2.	 Drag in the image to select the area you want to 
move. Be sure to leave enough of a margin that 
edge-region pixels can be suitably blended with 
background pixels.

Note: You can also make a selection prior to selecting 
the Content-Aware Move tool.

3.	 To adjust the selection, do one of the following:

•	 Shift-drag in the image to add to the existing 
selection.

•	 Alt-drag (Windows) or Option-drag (Mac OS) in 
the image to subtract from the existing selection.

•	 Alt+Shift-drag (Windows) or Option+Shift-drag 
(Mac OS) in the image to select an area 
intersected by the existing selection.

4.	 Position the pointer inside the selection, and drag the 
selection border to the area from which you want to 
move the selection (Figure 16). When you release the 
mouse button, the originally selected area is moved 
(Figure 17).

Figure 16 Dragging the image content to be moved

Figure 17 The final retouched image
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Sharpen using Smart Sharpen

Sharpening enhances the definition of edges in an image (Figure 18). Whether your images come from a digital 
camera or another source, most raw images can benefit from sharpening. The degree of sharpening needed 
varies depending on the quality of the source material. Keep in mind that sharpening cannot correct a severely 
blurred image. 

The Smart Sharpen filter offers enhanced controls not available with other sharpening filters (Figure 19). You can 
set the sharpening algorithm or control the amount of sharpening that occurs in shadow and highlight areas.

Figure 19 Smart Sharpen dialog box

Shadows/Highlights Preview option

Figure 18 Detail of original image (left); image after Smart Sharpen (right)
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To use the Smart Sharpen filter:

1.	 Open the image you want to sharpen.

2.	 Zoom into the document window to at least 100%, or 
larger; enough to get an accurate view of the image 
details. Do one of the following:

•	 Choose View > 100%, or another value such as 
200%

•	 Use the Zoom Tool from the Tools panel  
(Figure 20)

•	 Manually set a zoom level in the zoom level 
number field

3.	 Choose Filter > Sharpen > Smart Sharpen.

The Smart Sharpen dialog box opens (Figure 19).

4.	 Confirm the Preview option is selected and set the 
controls in the Smart Sharpen dialog box:

•	 Amount Sets the amount of sharpening. A higher 
value increases the contrast between edge pixels, giving the appearance of greater sharpness.

•	 Radius Determines the number of pixels surrounding the edge pixels affected by the sharpening. The greater 
the radius value, the wider the edge effects and the more obvious the sharpening.

•	 Reduce Noise Reduce unwanted noise while keeping important edges unaffected.

•	 Remove Sets the sharpening algorithm used to sharpen the image.

•	 Gaussian Blur is the method used by the Unsharp Mask filter.

•	 Lens Blur detects the edges and detail in an image, and provides finer sharpening of detail and reduced 
sharpening halos.

•	 Motion Blur attempts to reduce the effects of blur due to camera or subject movement. Set the Angle 
control if you choose Motion Blur option of the Remove control.

5.	 Click Shadow/Highlights to expand the options and adjust sharpening of dark and light areas using the Shadow 
and Highlight options. If the dark or light sharpening halos appear too strong you can reduce them with these 
controls, which are only available for 8- bits and 16-bits-per-channel images:

•	 Fade Amount Adjusts the amount of sharpening in the highlights or shadows.

•	 Tonal Width Controls the range of tones in the shadows or highlights that are modified. Move the slider to 
the left or right to decrease or increase the Tonal Width value. Smaller values restrict the adjustments to only 
the darker regions for shadow correction and only the lighter regions for highlight correction.

•	 Radius Controls the size of the area around each pixel that is used to determine whether a pixel is in the 
shadows or highlights. Moving the slider to the left specifies a smaller area, and moving it to the right specifies 
a larger area.

6.	 Click OK to close the Smart Sharpen dialog box.

Figure 20 Tools panel and zoom level

Zoom tool

Set zoom level
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Using the Camera Shake Reduction filter

Photoshop features an intelligent mechanism to automatically reduce image blurring caused by camera motion 
(Figure 21).

The Shake Reduction filter can reduce blurring resulting from several types of camera motion (Figure 22); 
including linear motion, arc-shaped motion, rotational motion, and zigzag motion. If necessary, you can adjust 
advanced settings to further sharpen the image.

Figure 21 Original image (left); image after camera-shake reduction (right)

Figure 22 Shake Reduction dialog box

Advanced settings

Detail loupe Unlock Detail 
loupe
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The camera shake reduction feature works best with decently lit still camera images having low noise. The 
following types of still images are particularly suitable for shake reduction:

•	 Indoor or outdoor images captured using a lens with a long focal length

•	 Indoor images of a static scene taken with a slow shutter speed and no flash

In addition, shake reduction can help sharpen blurred text in images affected by camera motion.

To use the Camera Shake Reduction filter:

1.	 Open the image.

2.	 Select Filter > Sharpen > Shake Reduction. Photo-
shop automatically analyzes the region of the image 
best suited for shake reduction, determines the nature 
of the blur, and extrapolates the appropriate correc-
tions to the entire image. The corrected image is 
displayed for your review in the Shake Reduction 
dialog box (Figure 22).

The Detail loupe in the lower-right pane lets you 
closely examine the region in focus. If necessary, 
zoom in or zoom out on an image element. As you 
drag the Hand tool over the Detail loupe to examine 
an image region, release the mouse button to see a quick 
preview of the shake reduction changes for that region.

3.	 Confirm the Preview option is selected then click the Undock Detail Loupe button.

The loupe window detaches and is placed over the image (Figure 23). You can move the Detail loupe around the 
image to focus on a new image region suitable for camera shake reduction.

4.	 If needed, use the options in the Advanced panel of the Shake Reduction dialog box to modify blur traces.

Figure 23 Undocked Detail loupe

https://edex.adobe.com/
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