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How to generate file formats
Different mediums—print, web and mobile, and video—require different file formats to achieve the 
best results. Furthermore, graphics file formats differ in the way they represent image data (as pixels 
or as vectors), and support different compression techniques. You need to understand the difference 
between these formats and know when to apply them to a project.

Adobe Photoshop supports a vast range of file formats (See Adobe Help for a complete list). This guide will describe 
the most common ones, and show you how to generate files for print, web and video mediums using Photoshop. To 
preserve all features (layers, effects, masks, and so on), be sure to save a copy of your image in Photoshop format (PSD) 
before exporting as another format. When generating any image in Photoshop, it’s important to remember that when 
you save an image, Photoshop saves the image as it appears onscreen. That is, if you have hidden some layers, they 
will not appear in the saved image. Download the assets used in this tutorial here.

Saving files for the web and mobile

The three most common image file formats used for the web are: Graphics Interchange Format (GIF), Joint 
Photographic Experts Group (JPEG or JPG), and Portable Network Graphics (PNG) (Figure 1). GIFs are great for simple, 
optimized graphics like logos with areas of flat color and no gradients. JPGs work well for photographs by keeping all of 
the color information intact while also compressing file size by selectively discarding data. PNGs suit complex images 
with gradients and transparency, where it’s important to see through to a background color or pattern in your web 
page or mobile app. 

You select one of these formats to achieve an ideal balance between quality of the image and file size. 

Figure 1 Comparing cmmon web image file formats: GIF (left), JPG (center), PNG (right)

GIF JPG PNG

https://helpx.adobe.com/photoshop/using/file-formats.html
https://adobe.ly/2yNHx3N
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You can specify the format type in the Export As dialog box (Figure 2).

GIF
GIFs are made up of pixels of indexed color, which means that it is limited to a reference library of 256 colors, plus 
transparency. These are not a lot of colors, so it is not suitable for images with a wide range, like a photograph. The 
limited palette does work very well for logos or simple illustrations, and for minimizing file size and electronic transfer 
time.

To save a file as a GIF:

1.	 In Photoshop, open an image that features flat areas of color.

2.	 Select File > Export > Export As to export the current Photoshop document.

The Export As dialog box opens (Figure 2).

3.	 Choose GIF from the Format menu. 

GIF images are transparent by default.

4.	 Set any of the other settings, such as:

•	 Size Specify the width and height of the image asset. Width and height are locked together by default. 
Changing the width automatically changes the height proportionately.

•	 Scale Choose how big the exported image should be. This option is useful for exporting larger- or smaller-
resolution assets. Changing the scale impacts the image size.

•	 Canvas Size If your asset needs to occupy a certain width and height, specify those values as the Canvas Size. 
This option is useful in several scenarios, such as the following:

•	 You’re exporting icons that have various sizes, but that need to be centered within 50x50 px boxes.

•	 You’re exporting banner images that are smaller or larger than the required dimensions.

Figure 2 Export As dialog box, , GIF settings
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4.	 Click Export All.

The Export dialog box opens.

5.	 Navigate to the location you want to export your image, specify a file name and click Save.

After you save, the original file stays open in Photoshop.

JPG
You will generally want to save photos in JPG format. JPG is used more than any other format for photos on web 
pages. JPG is popular because it compresses well—that is, you can make files smaller without sacrificing quality. 
However, if you compress too much, file quality will suffer; the trick is to find the right balance between image 
quality and compression. JPGs do not support transparency.

To save a file as a JPEG:

1.	 In Photoshop, open a photographic image.

2.	 Select File > Export > Export As to export the current Photoshop document.

The Export As dialog box opens (Figure 3).

3.	 Choose JPG from the Format menu. 

4.	 Click the Zoom setting to view the image at 100% or larger. 

Zooming in allows you to see degree of compression you will be setting in the next step.

5.	 Adjust for desired image quality by using the Quality slider.

Figure 3 Export As dialog box, JPG settings
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As you change settings, observe how the quality of preview appears compared to the file size. Ideally, you want to 
find the right balance between preserving compressed image quality against smallest file size.

6.	 Set any of the other settings as needed.

7.	 When you are satisfied, click Export All.

The Export dialog box opens.

8.	 Navigate to the location you want to export your image, specify a file name and click Save to automatically save a 
copy of the image as a JPG with the settings you indicated. The original image is left unchanged. For working 
purposes, you may want to incorporate some of the settings into the filename, such as “banner_medium.jpg” for an 
image saved as a medium-quality JPEG.

After you save, the original file stays open in Photoshop.

Note: If the original image is also a JPG (many digital cameras use JPG as a format), you need to save the copy in a 
different location from the original (or give it a different name) to avoid confusion.

PNG
PNG uses lossless compression. Lossless means that quality does not degrade during the editing process. PNGs 
tend to have larger file size than both GIFs and JPEGs because they contain more data, and offer more flexibility 
by being able to produce background transparency without jagged edges.

To save a file as a PNG:

1.	 In Photoshop, open or create an image with layers or transparencies.

2.	 Select File > Export > Export As to export the current Photoshop document.

The Export As dialog box opens (Figure 4).

Figure 4 Export As dialog box, PNG settings
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3.	 Choose PNG from the Format menu. 

4.	 Specify whether you want to export the image with Transparency enabled (32-bit) or Smaller File (8-bit).

Note: Bit refers to the depth of color contained within an image, with higher bits generally meaning better quality 
but higher file size. While exporting PNG assets, remember the following:

•	 Selecting Transparency generates a 32-bit PNG image. 32-bit is known as deep color. Deep color provides the 
highest level of color fidelity consisting of a billion or more colors. Use this option if you have a highly-de-
tailed image with delicate gradients and fine details, and file size is less of a concern.

•	 Selecting Smaller File generates an 8-bit PNG image. 8-bit color is a very limited but true direct color system. 
The maximum number of colors that can be displayed at any one time is 256. Select this option if small file 
size is most important, and exact color fidelity is not.

•	 Leaving the above options deselected generates a 24-bit PNG image. 24-bit renders true color. True color 
displays a very large number of colors, shades, and hues, up to ten million. As the default option, this setting is 
often best for striking the right balance between image quality and filesize.

5.	 Set any of the other settings as needed.

7.	 When you are satisfied, click Export All.

The Export dialog box opens.

8.	 Navigate to the location you want to export your image, specify a file name and click Save.

After you save, the original file stays open in Photoshop.

Generating files for print

Generating files for print use is different from saving images for the web: you use an uncompressed file format 
and you must be sure the file is at a high enough resolution (preferably 300 ppi) before you save it. It is always 
good to import the image into Photoshop at the highest possible resolution to give more flexibility in the kinds of 
images you can generate.

Note: You can print to a printer directly from any computer running Photoshop. The options described here are 
for sending an image to a printer, to another computer to be printed, or to another application.

Generating files for print involves three steps:

1.	 Setting the image resolution to 300 ppi.

2.	 Converting the image to CMYK (if the image is going to an offset print vendor).

3.	 Generating a print-friendly (compression-free or lossless) format, such as TIFF.

Setting resolution to 300 ppi
Setting a higher resolution is important to maintain flexibility and quality.

To set resolution to 300 ppi:

1.	 Open an image in Photoshop.
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2.	 Choose Image > Image Size.

The Image Size dialog box appears (Figure 5).

3.	 Deselect the Resample Image option if selected.

When you leave this option unselected, you ensure that you’re only changing the image’s resolution, not removing 
or adding pixels.

4.	 Enter 300 in the Resolution text box.

Make sure Pixels/Inch is selected as the units for Resolution.

5.	 Click OK.

To preview an image at the size it will appear when printed, choose View > Print Size.

Converting images to CMYK
Computers use combinations of red, green, and blue (RGB) to display photos. Offset printing presses print full-color 
photos, using cyan (blue), magenta (red), yellow, and black. This is known as CMYK printing. If you are printing to an 
inkjet printer, you can leave the image in RGB mode, but if you are sending the image to an offset print vendor, you 
need to convert the image to CMYK.

To view how the image will appear in CMYK, choose View > Proof Setup > Working CMYK. (For some images, you may 
not observe any difference at all.) This preview is called a soft proof.

Note: Soft proofs are approximations. What you see onscreen depends on the quality and settings of your monitor as 
well as the lighting conditions of your work environment. You may observe different results when you actually print. 
Nevertheless, soft proofs can be useful.

Photoshop also enables you to preview how the image will appear on a range of different printers, including most 
Epson models and offset printing. To view these, choose View > Proof Setup > Custom.

Figure 5 Image size dialog box

Set Resolution Resample option 
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To convert an image to CMYK:

1.	 Save a copy of the image.

2.	 Choose Image > Mode > CMYK Color.

3.	 If the image has layers, Photoshop asks whether you wish to flatten. Click Flatten. (Because you saved a copy of 
the file, you can open the saved copy to recover the layers.)

Generating TIFFs
After you convert the image to CMYK and make sure it is at the correct resolution, you can save it in a print-
friendly format (a format with no compression, known as a lossless format). In this exercise, you will choose the 
TIFF format.

Note: Although TIFF is the most common lossless image format, you can also use EPS or an Adobe PDF.

To generate a TIFF:

1.	 Choose File > Save As.

The Save As dialog box appears (Figure 6).

2.	 In the Save As Type format pop-up menu, choose TIFF (*.TIF, *.TIFF) (Windows) or TIFF (Mac OS).

Figure 6 Save As dialog box
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3.	 Click Save.

The TIFF Options dialog box appears (Figure 7).

4.	 Because the image is going to a printer, you do not need to compress it. Leave Image Compression set to None. 
Leave Pixel Order set to Interleaved.

Note: In practice, TIFF files are seldom compressed.

5.	 Set Byte Order to your operating system (Windows or Mac OS).

6.	 Because the image is going to a printer, you also don’t need to save the layers. Make sure Discard Layers And Save 
A Copy is selected.

This option flattens the layers in the image.

7.	 Click OK.

Note: If the image has only the Background layer, the option Discard Layers And Save A Copy is not available.

Printing images and saving print dialog settings
There may be occasions where you want to print a copy of your image to a local printer. Photoshop provides many 
printing options, including the following printing commands:

•	 Print Displays the Print dialog box, where you can preview the print job and select the printer, number of 
copies, output options, and color management options.

•	 Print One Copy Prints one copy of a file without displaying a dialog box.

Once you have established a preferred combination of format and color management options, you can save the print 
dialog settings as a preset for use later.

Figure 7 TIFF Options dialog box



9How to generate file formats  Photoshop Guide© 2018 Adobe Systems Incorporated. 
This document requires Adobe Photoshop CC 2018. Technical instructions may differ depending on your version.

To set Photoshop print options and print:

1.	 Choose File > Print.

The Print dialog box appears (Figure 8).

2.	 Do one or more of the following:

•	 Use the Printer menu to select a printer.

•	 Select the number of Copies to print.

•	 Set the paper orientation, or Layout, to portrait or landscape.

•	 If needed, click the Print Settings button to set page setup options specific to your printer, printer drivers, and 
operating system, such as paper size and layout.

•	 Set Color Management and proofing options

•	 Adjust the position and scale of the image in relation to the selected paper size and orientation.

•	 Set output options (Printing Marks and Functions)

3.	 Do one or more of the following:

•	 To print the image, click Print.

•	 To close the dialog box without changing the options, click Cancel.

•	 To preserve the options and close the dialog box, click Done.

Note: If you get a warning that your image is larger than the printable area of the paper, click Cancel, choose File > 
Print, and select the Scale To Fit Media option.

Figure 8 Print dialog box
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Creating images for video

Photoshop can create images of various aspect ratios so that they appear properly on devices such as video monitors. 
You can select a specific video option (using the New dialog box) to compensate for scaling when the final image is 
incorporated into video.

Safe zones
The Film & Video preset also creates a document with non-printing guides that delineate the action-safe and title-safe 
areas of the image (Figure 9). Using the options in the Size menu, you can produce images for specific video systems—
NTSC, PAL, or HDTV.

Safe zones are useful when you edit for broadcast and videotape. Most consumer TV sets use a process called 
overscan, which cuts off a portion of the outer edges of the picture, allowing the center of the picture to be enlarged. 
The amount of overscan is not consistent across TVs. To ensure that everything fits within the area that most TVs 
display, keep text within the title-safe margins, and all other important elements within the action-safe margins.

Figure 9 Video preset file size guides in a new document
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To create an image for use in video:

1.	 Create a new document.

The New document dialog box appears (Figure 10).

2.	 From the Document Type menu in the New dialog 
box, choose the Film & Video preset.

3.	 Choose the size that is appropriate for the video 
system on which the image will be shown.

In this case, the NTSC DV option is selected  
(Figure 11).

4.	 Click Advanced to specify a color profile and specific 
pixel aspect ratio.

Important: By default, non-square pixel documents 
open with Pixel Aspect Ratio Correction enabled. 
This setting scales the image so it appears as it would 
on the non-square pixel output device (usually a video 
monitor). This setting does not apply to all of the Film 
& Video presets.

Note: If you’re doing a project that requires the same 
format for other uses, it is helpful to save your custom 
setting as a preset for future use. To save a new 
document as a custom setting, click the Save Preset 
button, give your preset a name, and click OK  in the 
New Document Preset dialog box. (Figure 12).

5.	 Click OK to close the New document dialog box.

6.	 Click OK to close the message “Pixel aspect ratio 
correction is for preview purposes only. Turn it off for 
maximum image quality.” 

The new document opens (Figure 9).

Figure 10 New document dialog box
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Figure 12 New Document Preset dialog box
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7.	 To view the image as it would appear on a computer 
monitor (square pixel), choose View > Pixel Aspect 
Ratio Correction.

For example, in Figure 13, a circular image is shown 
displayed with Pixel Aspect Ratio Correction turned 
on and then turned off.

Note: You can simultaneously view an image with the 
Pixel Aspect Ratio Correction turned on and off. With 
the non-square pixel image open and Pixel Aspect 
Ratio Correction enabled, choose Window > Arrange 
> New Window For [name of document]. With the 
new window active, choose View > Pixel Aspect Ratio 
Correction to turn off the correction.

8.	 If you have a display device, such as a video monitor, 
connected to your computer, you can preview the 
document on the device by choosing File > Export > 
Render Video.

Note: When creating images for video, you can load a 
set of video actions (included with Photoshop) that 
automate certain tasks—such as scaling images to fit 
video pixel dimensions and setting the pixel aspect ratio.

Quickly share your creations

You can now email or share your creations to several services directly from within Photoshop (Figure 14). When you 
share a document by email, Photoshop sends out the original document (.psd file). For certain services and social 
media channels, Photoshop automatically converts the document to the JPEG format before sharing.

Figure 13 Circle in NTSC DV (720 x 480 pixels) 
document viewed on computer (square pixel) monitor 
with Pixel Aspect Ratio Correction turned on (top) and 
Pixel Aspect Ratio Correction turned off (bottom)

Figure 14 Quick share options on MacOS (left) and on Windows (right)
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To share your creations from within Photoshop:

1.	 In Photoshop, select File > Share. 

 The Share panel opens (Figure 14).

2.	 In the Share panel, choose whether you want to share the full-sized asset or a smaller version of it.

If you choose to share the smaller version, Photoshop scales down the document such that its longer edge is 1200 
px long. The other edge is scaled down proportionately.

3.	 Click the service where you want to share the asset. For example, click Facebook.

For some services, you may be able to specify additional details. For example, while posting an image on Facebook, 
you’re able to enter a “What’s on your mind?” description for the image (Figure 15).

4.	 Follow the onscreen instructions to share the asset.

Figure 15 Facebook Share dialog box

https://edex.adobe.com/
https://creativecommons.org/licenses/by-nc-sa/3.0/
https://creativecommons.org/licenses/by-nc-sa/3.0/

	How to generate file formats
	Saving files for the web 
	GIF
	JPG
	PNG

	Generating files for print 
	Setting resolution to 300 ppi 
	Converting images to CMYK 
	Generating TIFFs 
	Printing images and saving print dialog settings 

	Creating images for video 
	Safe zones 

	Quickly share your creations 


